Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Issue with Multiple Products Twilio products

        Incident Report for Twilio

        Resolved

        Multiple Twilio Products were degraded between 11:23 AM to 11:42 AM PT. Users may have experienced elevated latency or timeouts with account creation and deletion, call creation and modification, fetching voice recordings and voice transcriptions, phone number verification, or Impact Access program verification in Console.
        Posted Sep 11, 2023 - 13:43 PDT