Work with our downstream connectivity partners is complete and service has been restored to normal. If you continue to experience connectivity issues please open a support ticket with details.
Posted Nov 29, 2023 - 16:32 PST
Update
We are continuing to work with our downstream connectivity partners to restore normal connectivity.
Posted Nov 29, 2023 - 13:19 PST
Update
One of Super SIM's connectivity partners is experiencing an outage, and it is in process of performing emergency maintenance. We are observing impacted devices reconnecting on Super SIM's other available IMSIs. For customers in the United States devices solely dependent on Verizon, devices falling back to the other IMSIs will not be able to reconnect until our impacted connectivity partner restores services. If you are currently impacted in the US or other countries, consider enabling additional networks on your network access profile if possible. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Nov 29, 2023 - 11:12 PST
Investigating
At 09:30 pacific time, we started investigating an issue where some devices using Super SIM may experience delays in connecting to the network. Devices impacted by this issue have been observed reconnecting with different options. We are actively working to identify and resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.