Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Vodafone Egypt.
Incident Report for Twilio
Resolved
SMS delivery delays to Vodafone in Egypt have been resolved and SMS is operating normally at this time.
Posted May 17, 2020 - 07:01 PDT
Monitoring
We have resolved the issue causing SMS delivery delays to Vodafone in Egypt. Our engineers are continuing to monitor SMS deliveries to ensure there are no further problems.
Posted May 17, 2020 - 06:25 PDT
Update
Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as possible.
Posted May 17, 2020 - 05:05 PDT
Update
Our engineers are still investigating this issue with the underlying carrier. We will provide more updates as soon as possible.
Posted May 17, 2020 - 03:02 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Vodafone in Egypt. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 17, 2020 - 01:59 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).