Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
All inbound and outbound MMS and SMS messages are experiencing delays of 15 minutes or more
Incident Report for Twilio
Resolved
Our systems are operating normally at this time.
Posted 2 months ago. Mar 05, 2019 - 09:32 PST
Update
Our systems have recovered, all SMS and MMS messages are being processed and are no longer experiencing delivery delays.
Posted 2 months ago. Mar 05, 2019 - 09:16 PST
Monitoring
Our systems have recovered, all SMS and MMS messages are being processed and are no longer experiencing delivery delays.
Posted 2 months ago. Mar 05, 2019 - 08:54 PST
Update
Due to the ongoing issues with SMS and MMS delivery delays, we expect delays in price updates for SMS and Calls records that can take up to ~20-30 minutes.
Posted 2 months ago. Mar 05, 2019 - 08:49 PST
Update
We are continuing to work on this issue affecting SMS and MMS messages.
Posted 2 months ago. Mar 05, 2019 - 08:30 PST
Investigating
We are currently experiencing MMS and SMS delivery delays in all countries, we are working to restore service.
Posted 2 months ago. Mar 05, 2019 - 08:26 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS).