Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS/MMS Delivery Report Delays
Incident Report for Twilio
Resolved
Delays in processing message delivery reports and status callbacks have been resolved and the Programmable Messaging service is operating normally at this time.
Posted Oct 16, 2020 - 11:05 PDT
Monitoring
We are no longer experiencing delays in processing message delivery reports and status callbacks. We will continue to monitor the situation before we mark the incident as fully resolved.
Posted Oct 16, 2020 - 10:48 PDT
Identified
We are experiencing delays in processing message delivery reports and status callbacks. Our engineers have identified the issue and implemented a solution. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 16, 2020 - 10:44 PDT
Investigating
We are experiencing delays in processing message delivery reports and status callbacks. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 16, 2020 - 10:22 PDT
This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks) and PROGRAMMABLE MESSAGING (MMS, SMS).