Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay to T-Mobile Network in United States
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Jan 27, 2023 - 13:32 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to T-Mobile Network in the United States. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 27, 2023 - 11:41 PST
      Update
      We are experiencing SMS delivery delays when sending messages to T-Mobile Network in the United States. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 27, 2023 - 09:49 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to T-Mobile Network in the United States. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 27, 2023 - 09:34 PST
      Update
      We are experiencing SMS delivery delays when sending messages to T-Mobile Network in the United States. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 27, 2023 - 08:34 PST
      Investigating
      Our monitoring systems have detected a potential issue with SMS Delivery Delay to T-Mobile Network in the United States. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 27, 2023 - 08:24 PST
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).