We are no longer experiencing issues with Event Streams where events are being delivered with increased latency. The incident has been resolved.
Posted Oct 02, 2025 - 09:47 PDT
Monitoring
Our engineers have identified and mitigated the issue. Event Stream delivery lag is now showing signs of recovery. We will continue to monitor the situation and provide an update in 2 hours or as soon as more information becomes available.
Posted Oct 02, 2025 - 07:48 PDT
Update
We continue to experience issues with Event Streams where events are being delivered with increased latency. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 02, 2025 - 07:35 PDT
Investigating
Our engineers are investigating an issue in Event Streams where events are being delivered with increased latency.
Posted Oct 02, 2025 - 06:39 PDT
This incident affected: DEVELOPER TOOLS (Event Streams).