The issue affecting calls from Italian Network Subscribers to a subset of Twilio's numbers with the prefix +3904 has been resolved, and the service is functioning normally at this time.
Posted Sep 25, 2025 - 14:24 PDT
Monitoring
We have started seeing recovery for inbound calls from Italian Network Subscribers to a subset of Twilio's numbers with the prefix +3904. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2025 - 12:26 PDT
Update
We have identified that this incident is only impacting calls from Italian Network Subscribers to a subset of Twilio's numbers with the prefix +3904. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2025 - 10:27 PDT
Update
We are observing call failures to Twilio Italy phone numbers in the +390 range. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 25, 2025 - 09:49 PDT
Investigating
Our monitoring systems have detected a potential issue surrounding Voice Calls within a specific region. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 25, 2025 - 09:42 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).