Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Message delivery status delays to a subset of US Sprint recipients from Twilio Short codes
      Incident Report for Twilio
      Resolved
      The incident of SMS delivery status delays to US Sprint recipients from Twilio Short Codes is now resolved.
      Posted May 21, 2020 - 12:27 PDT
      Investigating
      We have detected delays in receiving message status events to a subset of US Sprint recipients from Twilio short codes. There is no impact to actual message delivery. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 21, 2020 - 12:01 PDT