Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Iraq Asia Cell
Incident Report for Twilio
Resolved
We are no longer seeing SMS delivery delays when sending messages to Asiacell in Iraq. This incident is now resolved.

Thanks,

Daniel
Posted Jun 25, 2020 - 00:44 PDT
Monitoring
We are seeing significant improvement in SMS delivery to the Asiacell network in Iraq. We are continuously and closely monitoring the issue until the mobile operator confirms the issue is resolved. We will provide an update as soon as it becomes available.
Posted Jun 24, 2020 - 22:25 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jun 24, 2020 - 17:16 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Asiacell in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 24, 2020 - 16:06 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).