Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures on China Mobile
Incident Report for Twilio
Resolved
We have reached out to affected customers to share more details on China Mobile ceasing support for GSM7-encoded messages and the recommended next-steps. With that, we are resolving the incident and will continue to work with affected customers via email.
Posted Nov 12, 2020 - 18:01 PST
Update
The message delivery failure for pre-registered GSM7-encoded SMS to China Mobile has been identified to be an issue on the mobile operator's end. Pre-registered Unicode messages are not affected. There's currently no ETA provided by the operator in restoring the service. Twilio will be reaching out to affected customers via email and recommend next steps.
Posted Nov 12, 2020 - 07:50 PST
Identified
We are experiencing delivery failures for pre-registered SMS messages encoded as GSM7 to China Mobile. Pre-registered Unicode messages are not affected and working as expected. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 20:00 PST
Update
We are experiencing delivery failures for pre-registered SMS messages encoded as GSM7 to China Mobile. Pre-registered Unicode messages are not affected and working as expected. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 12:00 PST
Update
We are experiencing delivery failures for pre-registered SMS messages encoded as GSM7 to China Mobile. Pre-registered unicode messages are not affected and working as expected. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 08:03 PST
Investigating
We are experiencing delivery failures sending GSM encoded messages to China Mobile. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 06:04 PST
This incident affected: CARRIER NETWORK (SMS, APAC).