Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jun 04, 2026 - 13:24 PDT
Update
Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 04, 2026 - 11:19 PDT
Identified
Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 04, 2026 - 10:18 PDT
Update
Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team is actively investigating this issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Jun 04, 2026 - 07:12 PDT
Update
Twilio customers may be experiencing SMS delivery delays and delivery failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jun 04, 2026 - 03:10 PDT
Update
Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 04, 2026 - 01:10 PDT
Investigating
Twilio customers may be experiencing SMS delivery delays and failures from Twilio to Babilon-M network subscribers in Tajikistan. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 04, 2026 - 00:01 PDT
This incident affects: CARRIER NETWORK (SMS, APAC).