Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound call failures to Barcelona DIDs
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted May 29, 2020 - 06:03 PDT
      Update
      This incident has been resolved. All services are operating normally.
      Posted May 29, 2020 - 06:03 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as the information becomes available.
      Posted May 29, 2020 - 05:25 PDT
      Investigating
      We are observing some call failures to Barcelona Phone numbers in the +3493* range. We will continue to monitor this situation and will provide an update as soon as more information becomes available.
      Posted May 29, 2020 - 03:11 PDT
      This incident affected: CARRIER NETWORK (Voice, Europe).