The incident has been resolved and User Authentication Identity in multiple countries across North America and Latin America is operating normally.
Posted Apr 10, 2026 - 02:32 PDT
Monitoring
We have observed a recovery in User Authentication Identity in USA, Brazil, Colombias across North America and Latin America and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 10, 2026 - 00:29 PDT
Investigating
Twilio customers may be experiencing User Authentication Identity API high latency across multiple networks in USA, Brazil, Colombia across North America and Latin America. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 09, 2026 - 23:39 PDT
This incident affected: CARRIER NETWORK (Lookup Identity Match, Lookup Line Type Intelligence [Legacy API], Lookup Line Type Intelligence [Twilio API], Lookup SIM Swap, Legacy Identity MatchAndAttributes).