Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issue With Programmable Messaging Caller IDs
Incident Report for Twilio
Resolved
Verified Caller IDs for International numbers were degraded from Oct 4th 1:00pm until Oct 13th 10:06am Pacific Time. During this period, customers may have experienced errors on console showing an incorrect verified called id number. The issue has now been resolved.
Posted Oct 13, 2021 - 09:23 PDT
Investigating
We've become aware of a potential issue with Programmable Messaging caller IDs. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 13, 2021 - 08:45 PDT
This incident affected: DEVELOPER TOOLS (Console, REST API) and TWILIO PLATFORM (Other).