Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
API partial outage
Incident Report for Twilio
Resolved
We have resolved the SSL issues for some outbound calls. Services are operating normally.
Posted about 3 years ago. Feb 24, 2016 - 23:34 PST
Identified
Some customers experiencing issues with SSL certificates on outbound requests.
Posted about 3 years ago. Feb 24, 2016 - 23:06 PST