Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Voice Quality Issue to Singapore
Incident Report for Twilio
Resolved
The issue affecting Voice Quality when calling to Singapore has been resolved, and the service is functioning normally at this time.
Posted Jun 11, 2021 - 10:29 PDT
Monitoring
We have started seeing recovery when calling to Singapore. Our engineers, working with our partner carrier, have implemented the required adjustments. We will continue to monitor to ensure a full recovery. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jun 10, 2021 - 10:30 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and calls from the Twilio platform to Singapore end users has been resolved. Calls from end users to Twilio Singapore phone numbers continue to experience voice quality issues and we are still actively working with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 21:13 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we continue to actively work with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Jun 09, 2021 - 10:33 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we continue to actively work with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Jun 08, 2021 - 18:33 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we continue to actively work with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Jun 08, 2021 - 10:38 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we continue to actively work with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 4 hour or as soon as more information becomes available.
Posted Jun 08, 2021 - 06:41 PDT
Update
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we are actively working with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 2 hour or as soon as more information becomes available.
Posted Jun 08, 2021 - 04:38 PDT
Identified
The issue causing voice quality degradation for calls to Singapore numbers has been identified and we are actively working with our carrier partner to resolve the issue as quickly as possible. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 08, 2021 - 03:38 PDT
Update
We are continuing to work with our carrier partner to investigate Voice Quality Issue when calling to Singapore. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 08, 2021 - 01:38 PDT
Update
We are continuing to work with our carrier partner to investigate Voice Quality Issue when calling to Singapore. We will provide another update in 1 hours or as soon as more information becomes available.
Posted Jun 08, 2021 - 00:38 PDT
Update
We are observing voice quality issue when calling to Singapore. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jun 08, 2021 - 00:08 PDT
Investigating
Our monitoring systems have detected a potential issue with voice quality issue to Singapore. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 07, 2021 - 23:55 PDT
This incident affected: CARRIER NETWORK (Voice, APAC).