Update
We are seeing continued improvement across most products; however, AWS is still performing remediation actions, and intermittent errors may continue until their work is fully complete. The majority of our services have recovered, however we are experiencing some service disruptions due to the AWS outage affecting the US-1 Region.
Recovery is progressing, and we are seeing improvement across most services. Programmable Voice, Flex & TaskRouter, Studio, Programmable Messaging, WhatsApp, SendGrid / Marketing Campaigns, Verify, and Lookup have largely recovered, though occasional transient errors may still occur.
Serverless – Functions and assets remains impacted, with continued latency errors and invocation failures. Event Streams is also facing delays in the delivery of some events. We are actively monitoring this service and working to resolve the issues.
Requests with a Twilio success code remain queued for delivery upon recovery, while those that resulted in failure codes will need to be resent once services are fully restored. We do not anticipate any data loss once recovery is complete. Twilio teams continue to work closely with AWS to address remaining connectivity and capacity issues and are monitoring the situation closely. We will provide another update within 60 minutes or as soon as additional information becomes available.
Posted Oct 20, 2025 - 13:18 PDT
Update
We continue to experience service disruptions due to the AWS outage affecting the US-1 Region. While recovery is well underway, full restoration is still in progress. Twilio teams are working closely with AWS to resolve remaining connectivity and capacity issues and to ensure ongoing stability across all regions.
We are seeing continued improvement across most products; however, AWS is still performing remediation actions, and intermittent errors may continue until their work is fully complete.
Key services impacted include Functions and Assets, which continue to experience invocation failures. Programmable Voice, Flex & TaskRouter, Studio, Programmable Messaging, and WhatsApp have largely recovered but may still encounter occasional transient errors. SendGrid / Marketing Campaigns customers may continue to see intermittent delays or errors when sending or managing campaigns. Verify traffic remains partially impacted, with a small portion (~0.1%) returning HTTP 503 errors and elevated latency. Lookup is recovering, but still shows increased latency.
Requests with a Twilio success code remain queued for delivery upon recovery, while those that resulted in failure codes will need to be resent once services are fully restored. We do not anticipate data loss once recovery is complete. Twilio has scaled systems to service current loads and continues to monitor the situation closely. We will provide an update within 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 12:34 PDT
Update
We continue to experience service disruptions due to the AWS update affecting the US-1 Region. While recovery is underway, full restoration is still in progress. Our teams are working closely with AWS to resolve connectivity and stability issues. The impact extends to cross-region networking and US1 east, causing intermittent performance degradation.
Key services impacted include Programmable Voice, Flex & TaskRouter, Studio, Functions, Assets, and Programmable Messaging, with varying degrees of recovery. For WhatsApp, a small number of MMS messages are experiencing delays, while non-MMS traffic appears to be functional and delivering on time. Requests with a Twilio success code are queued for delivery upon recovery, while those with failure codes need resending post-restoration. We anticipate no data loss once recovery is achieved. Twilio has scaled systems to service current loads and continues to monitor the situations. We will provide an update within 60 minutes or as soon as we have more information.
Posted Oct 20, 2025 - 11:48 PDT
Update
We continue to experience service disruptions due to the AWS update affecting the US-1 Region. While recovery is underway, full restoration is still in progress. Our teams are working closely with AWS to resolve connectivity and stability issues. The impact extends to cross-region networking and US1 east, causing intermittent performance degradation.
Key services impacted include Programmable Voice, Flex & TaskRouter, Studio, Functions, Assets, and Programmable Messaging, with varying degrees of recovery. For WhatsApp, a small number of MMS messages are experiencing delays, while non-MMS traffic appears to be functional and delivering on time. Requests with a Twilio success code are queued for delivery upon recovery, while those with failure codes need resending post-restoration. We anticipate no data loss once recovery is achieved. Twilio has scaled systems to service current loads and continues to monitor the situations. We will provide an update within 60 minutes or as soon as we have more information.
Posted Oct 20, 2025 - 10:48 PDT
Identified
We continue to experience service disruptions due to the AWS update affecting the US-1 Region. While recovery is underway, full restoration is still in progress. Our teams are working closely with AWS to resolve connectivity and capacity issues. The impact extends to cross-region networking and US1 east, causing intermittent performance degradation.
Key services impacted include Programmable Voice, Flex & Task Router, Studio, Functions, Assets, and Programmable Messaging with varying degrees of recovery. Requests with a Twilio success code are queued for delivery upon recovery, while those with failure codes need resending post-restoration. We anticipate no data loss once recovery is achieved. Twilio has scaled systems to service current loads and continues to monitor the situations. We will provide an update within 60 minutes or as soon as we have more information.
Posted Oct 20, 2025 - 09:49 PDT
Update
We are still experiencing outages across multiple product lines due to an ongoing AWS incident (https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
Our incident response team still has all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 09:25 PDT
Update
We are still experiencing outages across multiple product lines due to an ongoing AWS incident (https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
As mentioned earlier, our incident response team still has all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 08:21 PDT
Investigating
We are continuing our investigation and have discovered Programmable Messaging - Whatsapp and RCS media are affected by the Elevated Errors Affecting Multiple Products. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 07:16 PDT
Update
We have confirmed with AWS that they are experiencing issues, which is delaying recovery. We are working closely with AWS triage team to resolve the issue. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 06:54 PDT
Update
We are continuing our investigation and have discovered Programmable Messaging Conversation is affected by Elevated Errors Affecting Multiple Products. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 06:53 PDT
Update
We have confirmed with AWS that they are experiencing issues, which is delaying recovery. We are working closely with AWS triage team to resolve the issue. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 06:50 PDT
Update
We have confirmed with AWS that they are experiencing issues, which is delaying recovery. We are working closely with AWS triage team to resolve the issue. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 06:37 PDT
Identified
We are seeing partial recovery and are scaling systems to handle the influx of traffic. Programmable Messaging and Programmable Voice are fully recovered. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 05:47 PDT
Update
We are seeing partial recovery and are scaling systems to handle the influx of traffic. Programmable Messaging and Programmable Voice are fully recovered. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 05:31 PDT
Update
We are seeing partial recovery and are scaling systems to handle the influx of traffic. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 04:45 PDT
Update
We are seeing partial recovery and are scaling systems to handle the influx of traffic. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 04:34 PDT
Update
We are seeing partial recovery and are scaling systems to handle the influx of traffic. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. AWS has confirmed EC2 is impacted as well.
We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 03:48 PDT
Update
We are seeing partial recovery and are scaling systems to handle the influx of traffic. However we are still experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 03:21 PDT
Update
At this time we are experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 02:30 PDT
Update
At this time we are experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 01:37 PDT
Update
At this time we are experiencing outages across multiple product lines due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. We have activated our incident response team and have all hands on deck working on remediation. We are partnering directly with AWS on the incident and have also escalated to their leadership. At this time we do not recommend trying to take any failover action to alternative Regions. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 01:08 PDT
Investigating
We are currently investigating elevated latency and timeout errors for Twilio Rest API, impacting the Multiple Twilio services. Our engineering team is actively working on the issue, and we will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 00:26 PDT
This incident affects: DEVELOPER TOOLS (Console, Event Streams, Debugger & Alarms, Documentation, REST API, Bulk Export), SERVERLESS (Studio, Functions, Assets, TwiML Bins, Sync), FLEX (Flex Application Platform, TaskRouter, Flex Insights, Flex Agent Desktop, Flex Queue Stats, Flex Teams View, Flex Admin Console, Flex Routing, Flex Conversations, Flex Programmable Chat, Flex Programmable Voice, Proxy, Flex Plugins, Flex Billing), PROGRAMMABLE VIDEO (Group Rooms, Peer-to-Peer Rooms, Recordings, Compositions, Network Traversal Service, Go Rooms, Video Insights), ZIPWHIP TOOLS (Zipwhip Provisioner Dashboard and API, Zipwhip Support Ticketing, Toll-Free Verification Portal), TWILIO PLATFORM (Billing, Customer Support Center, Other, Account Insights, Trust Hub, Organization), INTERCONNECT, PHONE NUMBERS, PROGRAMMABLE CHAT, PROXY, FRONTLINE, Sender ID, PROGRAMMABLE MESSAGING (MMS, SMS, SMPP, Messaging Channels, Notify, Conversations, Messaging Insights, Messaging Services, Content API, Toll-free verification, RCS Messaging), and CARRIER NETWORK (Verify Silent Network Auth, Lookup Identity Match, Lookup Line Type Intelligence [Legacy API], Lookup Line Type Intelligence [Twilio API], Lookup SIM Swap, Legacy Identity MatchAndAttributes).