We are continuing to experience SMS delivery delays when sending messages to and from multiple networks in the United States of America and Guam. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Dec 08, 2025 - 19:02 PST
Update
We are continue experiencing SMS delivery delays when sending messages to To and From Multiple Networks In United States of America and Guam. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Dec 08, 2025 - 11:05 PST
Update
We are continue experiencing SMS delivery delays when sending messages to To and From Multiple Networks In United States of America and Guam. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Dec 08, 2025 - 07:14 PST
Update
We are experiencing SMS delivery delays when sending messages to To and From Multiple Networks In United States of America and Guam. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 08, 2025 - 05:12 PST
Update
We are continuing to investigate this issue.
Posted Dec 08, 2025 - 04:40 PST
Investigating
We are experiencing SMS delivery delays when sending messages to To and From Multiple Networks In United States of America and Guam. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 08, 2025 - 04:28 PST
This incident affects: CARRIER NETWORK (SMS Short Code, North America).