Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Unable to See Pay Connector in Catalog in US1 Region
      Incident Report for Twilio
      Resolved
      The issue with Pay connectors in US1 region of catalog has been resolved and is operating normally at this time.
      Posted Dec 09, 2024 - 07:33 PST
      Monitoring
      Pay connectors in US1 region of catalog are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 09, 2024 - 07:11 PST
      Identified
      Our engineers have identified the issue with Pay connectors in US1 region of catalog, causing customers to be unable to see any Pay connectors and are working to deploy a fix. For customers who have already installed connectors, the ability to perform transactions is not affected. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 09, 2024 - 07:02 PST
      Investigating
      We've become aware of a potential issue with Pay Connector. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 09, 2024 - 06:45 PST