Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound MMS Delivery Delays for US Short Codes
Incident Report for Twilio
Resolved
The delivery issues have been resolved and all systems are operating normally
Posted 7 months ago. Feb 03, 2019 - 14:36 PST
Investigating
We are observing delays in delivering outbound MMS over a subset of US Short Codes. We are actively working with our carrier partners for a resolution.
Posted 7 months ago. Feb 03, 2019 - 13:42 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).