Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Delays to Toll-Free Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS and MMS delivery delays when sending messages to Toll-Free numbers. This incident has been resolved.
      Posted Nov 15, 2022 - 11:38 PST
      Update
      We are observing recovery in SMS and MMS delivery delays when sending messages to Toll-Free numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update within 2 hours or as soon as more information becomes available.
      Posted Nov 15, 2022 - 11:25 PST
      Monitoring
      We are observing recovery in SMS and MMS delivery delays when sending messages to Toll-Free numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update within 30 minutes or as soon as more information becomes available.
      Posted Nov 15, 2022 - 10:56 PST
      Update
      We are continuing to investigate SMS and MMS delivery delays when sending messages to Toll-Free numbers. Our engineers are working on a resolution. We will provide another update within 2 hours or as soon as more information becomes available.
      Posted Nov 15, 2022 - 10:00 PST
      Update
      We are continuing to investigate SMS and MMS delivery delays when sending messages to Toll-Free numbers. Our engineers are working on a resolution. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 15, 2022 - 09:00 PST
      Update
      We are experiencing SMS and MMS delivery delays when sending messages to Toll-Free numbers. Our engineers are working on a resolution. We will provide another update in 30 minutes or as soon as more information becomes available.
      Posted Nov 15, 2022 - 08:32 PST
      Investigating
      Our monitoring system has detected a potential issue with Toll-Free delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 15, 2022 - 08:18 PST
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America, MMS Toll-Free, North America).