Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to C&W Panama
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures to C&W Panama. This incident has been resolved.
      Posted Jul 25, 2020 - 15:00 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to C&W Panama. Our engineers are continuing to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 25, 2020 - 13:56 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to C&W Panama. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 25, 2020 - 12:56 PDT
      This incident affected: CARRIER NETWORK (SMS, Latin America).