Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to DigiTel Venezuela
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to DigiTel Venezuela. This incident has been resolved.
      Posted Jan 18, 2021 - 18:03 PST
      Update
      We are observing successful SMS delivery when sending messages to DigiTel Venezuela. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 18, 2021 - 17:17 PST
      Monitoring
      We are observing successful SMS delivery when sending messages to DigiTel Venezuela. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 18, 2021 - 15:24 PST
      Update
      Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Jan 18, 2021 - 01:50 PST
      Update
      Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Jan 17, 2021 - 17:50 PST
      Update
      Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 17, 2021 - 13:57 PST
      Update
      Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 17, 2021 - 11:55 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to DigiTel Venezuela. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 17, 2021 - 10:58 PST
      This incident affected: CARRIER NETWORK (SMS, Latin America).