Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Short codes delivery delay in US towards T-Mobile
Incident Report for Twilio
Resolved
```The issue has been resolved and all systems are operating normally```
Posted 8 months ago. Aug 09, 2018 - 06:04 PDT
Monitoring
We are seeing recovery in Short Code delivery delay towards T-mobile handsets. Our engineering team will continue to monitor the service.
Posted 8 months ago. Aug 09, 2018 - 05:40 PDT
Identified
We have detected an issue with delay in delivery of messages from Shortcodes in US towards T-Mobile. Our engineers have escalated with the carrier partner and carrier partner is investigating the issue.
Posted 8 months ago. Aug 09, 2018 - 05:20 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).