Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delays from US Cellular handsets to a subset of shortcodes in the US
Incident Report for Twilio
Resolved
All systems are now working as designed.
Posted 17 days ago. Sep 07, 2019 - 10:35 PDT
Investigating
We are observing a delivery degradation in receiving SMS sent from US Cellular handsets and delays in receiving delivery receipts when sending messages to a subset of shortcodes in the US. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 17 days ago. Sep 07, 2019 - 08:48 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).