Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Accounts with JPY as currency cannot open support plans page
      Incident Report for Twilio
      Resolved
      Our engineers have identified the fix for the issue impacting accounts with JPY currency being unable to access the support plans page. We will be reaching out to affected customers directly.
      Posted Apr 02, 2020 - 16:04 PDT
      Update
      We are continuing to work on a fix for the issue that is preventing customers from accessing the support plans page.
      Posted Apr 02, 2020 - 14:18 PDT
      Update
      We are continuing to work on a fix for this issue.
      Posted Apr 02, 2020 - 10:02 PDT
      Identified
      The issue has been identified and the engineering team is working on implementing a fix. We will provide further updates as the information becomes available.
      Posted Apr 02, 2020 - 05:58 PDT
      Update
      Our engineers are continuing to work to resolve the issue. We will provide further updates as the information becomes available.
      Posted Apr 02, 2020 - 03:48 PDT
      Investigating
      We have detected an issue where Twilio accounts with JPY as current are not able to access the support plans page within the console. Our engineers are working to resolve the issue.
      Posted Apr 02, 2020 - 02:24 PDT
      This incident affected: TWILIO PLATFORM (Customer Support Center).