Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Lookup API Returning Inconsistent Results
      Incident Report for Twilio
      Resolved
      Twilio Lookup API was degraded for 47 days between June 8th 12:00 PM and July 25th 1:50 AM Pacific Time. During this period of time, customers may have experienced issues retrieving information in around 0.1% of API calls. The issue has now been resolved.
      Posted Sep 17, 2024 - 11:06 PDT
      Monitoring
      Our engineers are currently investigating the customer impact of a retroactive issue with Lookup. We will follow up and provide customer impact details within 2 hours.
      Posted Sep 17, 2024 - 10:00 PDT
      This incident affected: ACCOUNT SECURITY (Lookup).