Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays Over Mexico TelCel(334-020)
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays over Mexico TelCel(334-020). This incident has been resolved.
      Posted Mar 05, 2021 - 17:01 PST
      Monitoring
      We are observing recovery in SMS delivery delays Mexico TelCel(334-020)]. We will continue monitoring the service to ensure a full recovery. We will provide another update in 60 minutes or as soon as more information becomes available.
      Posted Mar 05, 2021 - 16:07 PST
      Update
      We are experiencing SMS delivery delays when sending messages to Mexico TelCel(334-020). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 05, 2021 - 15:10 PST
      Update
      Our monitoring systems have detected an issue with SMS delivery Delays over Mexico TelCel(334-020). Our engineering team is working with our carrier partner to resolve SMS delivery Delays over Mexico TelCel(334-020). We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 05, 2021 - 14:28 PST
      Identified
      Our monitoring systems have detected a potential issue with SMS delivery Delays over Mexico TelCel(334-020). Our engineering team is working with our carrier partner to resolve SMS delivery Delays over Mexico TelCel(334-020). We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 05, 2021 - 14:27 PST
      Update
      Our monitoring systems have detected a potential issue with SMS delivery Delays over Mexico TelCel(334-020). Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 05, 2021 - 14:13 PST
      Update
      Our monitoring systems have detected a potential issue with SMS delivery Delays over Mexico TelCel(334-020). Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 05, 2021 - 14:13 PST
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery Delays over Mexico TelCel(334-020). Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 05, 2021 - 14:11 PST
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).