Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Intermittent Delays in MMS Message Delivery
      Incident Report for Twilio
      Resolved
      MMS message delivery has been restored to normal operation.
      Posted Mar 29, 2016 - 21:11 PDT
      Monitoring
      MMS message delivery has been restored to normal performance, and all queued messages have been delivered.
      Posted Mar 29, 2016 - 20:58 PDT
      Update
      We continue to see delays delivering some MMS messages. Our engineering is working to resolve the issue.
      Posted Mar 29, 2016 - 20:39 PDT
      Update
      We have confirmed that a percentage of MMS messages are experiencing delays in delivery. Our engineering teams are working with out partners to resolve this issue as soon as possible. We expect to deliver queued messages at the time the issue is resolved.
      Posted Mar 29, 2016 - 19:15 PDT
      Identified
      Our engineering team is investigating an increase in delays delivering some MMS messages.
      Posted Mar 29, 2016 - 18:39 PDT