Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays Over Subset of Short Codes to Multiple US Networks
Incident Report for Twilio
Resolved
The incident causing MMS delivery report delays has been resolved, except for a small number of customers. We are closing this incident and will reach out to these customers individually for further follow-ups.
Posted Sep 09, 2021 - 15:57 PDT
Update
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 08, 2021 - 21:17 PDT
Update
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 07, 2021 - 21:17 PDT
Update
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 06, 2021 - 21:17 PDT
Update
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 05, 2021 - 21:17 PDT
Update
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 04, 2021 - 21:25 PDT
Identified
We are no longer experiencing MMS delivery delays over a subset of Short Codes to multiple US networks. Our engineers are now working with our carrier partner to resolve MMS delivery report delays issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Sep 03, 2021 - 21:25 PDT
Update
We are experiencing MMS delivery delays or MMS delivery report delays over a subset of Short Codes to multiple US networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Sep 03, 2021 - 08:43 PDT
Update
We are experiencing MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Sep 03, 2021 - 00:43 PDT
Update
We are experiencing MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 20:44 PDT
Update
We are experiencing MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 18:51 PDT
Investigating
We are experiencing MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 02, 2021 - 17:52 PDT
Monitoring
We are observing recovery in MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 17:22 PDT
Update
We are experiencing MMS delivery delays over a subset of Short Codes to Verizon and AT&T Networks. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 13:23 PDT
Update
We are experiencing MMS delivery delays to multiple US networks over a subset of shortcodes Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 11:58 PDT
Investigating
We are experiencing MMS delivery delays to multiple US networks over a subset of shortcodes Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 02, 2021 - 11:01 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).