Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delays
Incident Report for Twilio
Resolved
SMS queues have drained. All services are fully operational.
Posted about 1 year ago. Mar 02, 2018 - 10:31 PST
Update
Message queues continuing to drain. We are continuing active monitoring.
Posted about 1 year ago. Mar 02, 2018 - 09:47 PST
Monitoring
We are observing recovery. Messages are still delayed as queues clear. We would expect all queues to clear within the next 10 minutes.
Posted about 1 year ago. Mar 02, 2018 - 09:33 PST
Identified
We are working on reducing delays and restoring service to affected short codes. We are also seeing delays on MMS messages.
Posted about 1 year ago. Mar 02, 2018 - 09:09 PST
Update
We are working on migrating traffic to a new site to restore inbound service on Verizon and impacted Short Codes
Posted about 1 year ago. Mar 02, 2018 - 08:38 PST
Investigating
We are experiencing delays on inbound SMS messages from Verizon and message failures on outbound and inbound messages on a subset of short codes. We are also experiencing delays in inbound messages in France & Brazil. Team is troubleshooting the issue
Posted about 1 year ago. Mar 02, 2018 - 07:09 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).