Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Network Connectivity Issues
Incident Report for Twilio
Resolved
Super SIM connectivity issue has been resolved and Super SIM product is operating normally at this time.
Posted Oct 14, 2020 - 14:51 PDT
Monitoring
We are now seeing recovery of the network connectivity issue. We are continuing to monitor for service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 14, 2020 - 13:52 PDT
Investigating
We are experiencing Super SIM connectivity issues for a subset of customers. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 14, 2020 - 13:40 PDT
This incident affected: INTERNET OF THINGS (Super SIM).