Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics
        SMS Delivery Failures to Ethio Telecom In Ethiopia
        Incident Report for Twilio
        Resolved
        We are no longer experiencing SMS delivery failures to Telecom In Ethiopia. This incident has been resolved.
        Posted Feb 17, 2025 - 13:42 PST
        Update
        We are continuing to experience SMS delivery failures to Ethio Telecom In Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
        Posted Feb 17, 2025 - 11:35 PST
        Update
        We are continuing to experience SMS delivery failures to Ethio Telecom In Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Feb 17, 2025 - 09:35 PST
        Investigating
        We are experiencing SMS delivery failures to Ethio Telecom In Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
        Posted Feb 17, 2025 - 08:35 PST
        This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).