Our Engineering team has identified the root cause of the delay in updating Voice pricing for calls. Remediation steps have been implemented, and we are now observing signs of recovery. We are closely monitoring the system to ensure continued stability. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Jul 28, 2025 - 18:25 PDT
Monitoring
Our Engineering team has identified the root cause of the delay in updating Voice pricing for calls. Remediation steps have been implemented, and we are now observing signs of recovery. We are closely monitoring the system to ensure continued stability. We will provide an update in 2 hours or as soon as more information becomes available.
Posted Jul 28, 2025 - 16:25 PDT
Update
Our Engineering team has identified the problem causing the delay in updating Voice pricing for calls. The team has implemented the remediations and are starting to see recovery. We will provide an update in 4 hours or as soon as more information becomes available.
Posted Jul 28, 2025 - 15:40 PDT
Identified
Our Engineering team has identified the problem causing the delay in updating Voice pricing for calls. The team has implemented the remediations and are starting to see recovery. We will provide an update in 2 hours or as soon as more information becomes available.
Posted Jul 28, 2025 - 13:40 PDT
Update
We are currently experiencing a delay in updating voice call pricing. Our engineers are actively working with our carrier partner to resolve the issue. As a result, customers may not see updated prices for calls, recordings, and transcriptions at this time. We will provide an update in 2 hours or as soon as more information becomes available.
Posted Jul 28, 2025 - 13:06 PDT
Update
We are experiencing a delay in voice call pricing updates. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Jul 28, 2025 - 12:14 PDT
Investigating
We are experiencing a delay in voice call pricing updates. Our engineers are working with our carrier partner to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Jul 28, 2025 - 12:14 PDT
This incident affects: PROGRAMMABLE VOICE (Voice REST API).