Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery failures to Movilnet Venezuela
Incident Report for Twilio
Resolved
Delivery to Movilnet in Venezuela has been restored. The service is operating normally.
Posted 14 days ago. Mar 10, 2019 - 15:02 PDT
Investigating
We have detected message delivery failures to Movilnet users in Venezuela. We are working with our carrier partner to resolve the issue.
Posted 14 days ago. Mar 10, 2019 - 11:47 PDT
This incident affected: CARRIER NETWORK (SMS, Latin America).