Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Message and Delivery Receipt (DLR) delays From Shortcodes to T-Mobile Handsets in the United States
      Incident Report for Twilio
      Resolved
      We have observed recovery of messages and delivery receipts from shortcodes to T-Mobile handsets in the US for 60 minutes. All services are fully operational.
      Posted Aug 17, 2018 - 16:23 PDT
      Monitoring
      We continue to observe recovery for message and delivery receipts from shortcodes to T-Mobile handsets in the US. We will provide the next update in 60 minutes.
      Posted Aug 17, 2018 - 15:51 PDT
      Update
      We are observing improvement in message and DLR delivery from shortcodes to T-Mobile handsets in the US. We continue to work with our carrier partner and will provide an update when we confirm service restoration.
      Posted Aug 17, 2018 - 15:03 PDT
      Update
      We continue to see messages and DLRs for shortcodes failing to reach T-Mobile handsets in the US. Our engineers are working with our carrier partners and we will provide an update as soon as we have new information.
      Posted Aug 17, 2018 - 13:48 PDT
      Investigating
      We are experiencing message and DLR delays from shortcodes to T-Mobile handsets in the US. We are working with our carrier partner and will provide an update within 60 minutes or as soon as we have more information.
      Posted Aug 17, 2018 - 13:24 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).