Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays on US AT&T
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delivery delays to US AT&T from a subset of short codes. This incident has been resolved.
Posted Jan 03, 2021 - 19:29 PST
Monitoring
We are observing improvements in MMS delivery. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 03, 2021 - 18:03 PST
Update
We are still experiencing MMS delivery delays to US AT&T from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 03, 2021 - 15:35 PST
Update
We are still experiencing MMS delivery delays to US AT&T from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 03, 2021 - 13:36 PST
Investigating
We are experiencing MMS delivery delays to US AT&T from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 03, 2021 - 12:29 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).