Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inconsistent SMS status callback to BSNL/Cellone Haryana in India
Incident Report for Twilio
Resolved
We are no longer experiencing status callback delays for messages to BSNL/Cellone Haryana in India. This incident has been resolved.
Posted Jun 20, 2020 - 13:24 PDT
Monitoring
We are observing successful status callbacks for the messages to BSNL/Cellone Haryana in India. We will continue to monitor to ensure a full recovery.
Posted Jun 20, 2020 - 11:48 PDT
Update
We are continuing to investigate this issue.
Posted Jun 20, 2020 - 09:28 PDT
Investigating
We are experiencing inconsistent status callback issue from Twilio to BSNL/Cellone Haryana in India. The inconsistent false delivery report (failed/expired) might appear although there is no impact to the actual message delivery. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 20, 2020 - 08:42 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).