Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Issues with E911 address activation
Incident Report for Twilio
Resolved
We are no longer observing E911 address activation failures. This incident has been resolved.
Posted Jul 29, 2020 - 07:30 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 29, 2020 - 05:34 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 29, 2020 - 03:28 PDT
Monitoring
E911 address activation is now operating normally. We will continue to monitor the situation before we mark the incident as fully resolved.
Posted Jul 29, 2020 - 02:46 PDT
Identified
The issue has been identified and our engineering team is working on a resolution. We will provide a further update within 1 hour.
Posted Jul 29, 2020 - 01:52 PDT
Update
We are experiencing an issue with E911 address activation, customers are currently unable to associate new E911 addresses with their Twilio phone numbers. Currently configured numbers and existing addresses are not affected. We will provide an update within 30 minutes.
Posted Jul 29, 2020 - 01:13 PDT
Investigating
Our monitoring systems have detected a potential issue with Phone Number E911 functionality. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 29, 2020 - 00:42 PDT
This incident affected: PHONE NUMBERS.