Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays on Alpha Register Sender IDs in Mexico
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Mexico from registered Alphanumeric Sender IDs. This incident has been resolved.
      Posted Sep 21, 2022 - 17:39 PDT
      Monitoring
      We are observing recovery in SMS delivery delays for messages sent from Alpha Register Sender IDs in Mexico. We will continue monitoring the service to ensure a full recovery. We will provide another update in [X hours] or as soon as more information becomes available.
      Posted Sep 21, 2022 - 15:47 PDT
      Update
      We continue to experience SMS delivery delays for messages sent from Alpha Register Sender IDs in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 21, 2022 - 12:48 PDT
      Update
      We continue to experience SMS delivery delays for messages sent from Alpha Register Sender IDs in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 21, 2022 - 10:48 PDT
      Update
      We are experiencing SMS delivery delays for messages sent from Alpha Register Sender IDs in Mexico. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 21, 2022 - 09:50 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery delays on Alpha Register sender ID in Mexico. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 21, 2022 - 09:46 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).