Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery failures to Nigeria Airtel (621-20)
Incident Report for Twilio
Resolved
We have confirmed that we are now delivering messages to Nigeria Airtel. All services are operational.
Posted 2 months ago. Jun 05, 2019 - 18:45 PDT
Identified
We are unable to deliver messages to Nigeria Airtel (mcc-mnc: 621-20). We are working with our providers to address this issue. We will continue to monitor and provide an update.
Posted 2 months ago. Jun 05, 2019 - 16:04 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).