Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delays to Zain & Umniah networks in Jordan
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 01, 2018 - 04:42 PDT
Monitoring
We are observing recovery in SMS delivery latency to the Zain and Umniah networks in Jordan. SMS traffic is now delivering without any issues. Our engineering teams will continue to monitor and provide an update as soon as possible.
Posted 9 months ago. Oct 01, 2018 - 04:24 PDT
Investigating
We are observing increased SMS delivery latency to the Zain and Umniah networks in Jordan. We are working with our carrier partners to resolve the issue and will provide an update as soon as possible.
Posted 9 months ago. Oct 01, 2018 - 02:38 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).