Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Trial accounts in GBP Currency Getting Incorrectly Suspended
Incident Report for Twilio
Resolved
Trial accounts using GBP currency is operating normally at this time.
Posted Feb 10, 2021 - 17:56 PST
Monitoring
Trial accounts using GBP currency are now operating normally and is no longer suspending. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 10, 2021 - 17:27 PST
Update
We are addressing the trial accounts being suspended using GBP currency on the Twilio platform. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 17:10 PST
Identified
We are addressing the trial accounts being suspended using GBP currency on the Twilio platform. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 10, 2021 - 16:01 PST
Update
We are experiencing trial accounts being suspended using GBP currency on the Twilio platform. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 15:42 PST
Update
We are experiencing trial accounts being suspended using GBP currency on the Twilio platform. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 10, 2021 - 14:44 PST
Investigating
Our monitoring systems have detected a potential issue with trial accounts. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 10, 2021 - 14:36 PST
This incident affected: TWILIO PLATFORM (Billing).