Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays to AT&T Network in the US
      Incident Report for Twilio
      Update
      We continue experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes and toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 08, 2022 - 17:12 PDT
      Update
      We continue experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes and toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 07, 2022 - 16:48 PDT
      Update
      We continue experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes and toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 06, 2022 - 16:56 PDT
      Update
      We are still experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 05, 2022 - 16:56 PDT
      Update
      We are still experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Aug 04, 2022 - 16:56 PDT
      Update
      We are still experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in the next 16 hours or as soon as more information becomes available.
      Posted Aug 04, 2022 - 00:50 PDT
      Update
      We are still experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 16:57 PDT
      Update
      We are still experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 12:57 PDT
      Update
      We are experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 10:50 PDT
      Investigating
      We are experiencing MMS delivery report delays to AT&T network in the US over a subset of short codes & toll free numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 03, 2022 - 09:55 PDT
      This incident affects: CARRIER NETWORK (MMS Short Code, North America, MMS Toll-Free).