Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex WFO outage
Incident Report for Twilio
Resolved
The issue was resolved.
Posted Nov 07, 2019 - 06:02 PST
Monitoring
Flex WFO has recovered. We are processing the backlog and will provide an update when it has completed.
Posted Nov 07, 2019 - 05:33 PST
Investigating
Our Flex WFO is currently unavailable, Our engineers are investigating the issue, We will provide an update as quickly as possible.
Posted Nov 07, 2019 - 04:49 PST
This incident affected: CONTACT CENTER (Flex WFO).