Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay to Cubacel Cuba
Incident Report for Twilio
Resolved
We are no longer experiencing delivery report delays when sending to the Cubacel network in Cuba. This incident has been resolved.
Posted Feb 12, 2021 - 02:58 PST
Update
We are observing improvement in SMS delivery to the Cubacel network in Cuba. Our engineers are monitoring the issue. We will provide another update in 2 hours or as soon as more information is available.
Posted Feb 12, 2021 - 01:06 PST
Monitoring
We are observing improvement in SMS delivery to the Cubacel network in Cuba. Our engineers are monitoring the issue. We will provide another update in 2 hours or as soon as more information is available.
Posted Feb 11, 2021 - 23:04 PST
Update
We are still experiencing SMS delivery delays to the Cubacel network in Cuba. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 11, 2021 - 22:15 PST
Investigating
We are still experiencing SMS delivery delays to the Cubacel network in Cuba. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 11, 2021 - 21:15 PST
Monitoring
We are observing improvement in SMS delivery to the Cubacel network in Cuba. Our engineers are monitoring the issue. We will provide another update in 2 hours or as soon as more information is available.
Posted Feb 11, 2021 - 19:15 PST
Update
We are still experiencing SMS delivery delays to the Cubacel network in Cuba. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
Posted Feb 11, 2021 - 17:25 PST
Update
We are experiencing SMS delivery failures to the Cubacel network in Cuba. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 11, 2021 - 16:32 PST
Investigating
Our monitoring systems have detected a potential issue with SMS delivery to Cubacel Cuba. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 11, 2021 - 16:19 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).