Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        High Service Latency Issues for Customer Integrations with Adyen <pay> Platform

        Incident Report for Twilio

        Resolved

        The issue causing high service latency for customer integrations with Adyen platform has been resolved and the service is functioning normally at this time. This incident has been resolved. Please refer here for more details - https://www.adyen.com/landing/platform-status.
        Posted Mar 16, 2023 - 14:25 PDT

        Identified

        Twilio has detected high service latency for customer integrations with Adyen platform . Customers may experience failures of payments via and Pay Agent Assist due to an incident with Adyen. Please see their status page at https://status.adyen.com/
        Posted Mar 16, 2023 - 12:56 PDT