Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in Processing Voice Recordings
Incident Report for Twilio
Resolved
We are no longer experiencing delays in processing voice recordings and all metadata for affected recordings has been recovered. This incident has been resolved.
Posted Jul 03, 2020 - 10:32 PDT
Update
The engineering team is continuing to work on this issue to ensure a full recovery. We will provide further updates as more information becomes available.
Posted Jul 03, 2020 - 09:54 PDT
Update
The engineering team is continuing to work on this issue to ensure a full recovery. We will provide further updates as more information becomes available.
Posted Jul 03, 2020 - 05:54 PDT
Update
We have started seeing recovery for voice recordings. This issue impacted the processing of a subset of voice recordings and recording availability in Flex Insights. The engineering team is continuing to work on this issue to ensure a full recovery.
Posted Jul 03, 2020 - 03:51 PDT
Update
Our engineers are working to restore the service and we will provide an update as quickly as possible.
Posted Jul 03, 2020 - 03:28 PDT
Investigating
Our monitoring systems have detected a potential issue where some voice recordings are taking longer than expected to be processed and there may be delays in receiving completion callbacks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 03, 2020 - 02:25 PDT
This incident affected: FLEX (Flex Insights) and PROGRAMMABLE VOICE (Recording).