Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures to Venezuela Digitel (734-02)
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Venezuela Digitel (734-02). This incident has been resolved.
      Posted Nov 17, 2021 - 08:21 PST
      Monitoring
      We are observing successful SMS delivery to Venezuela Digitel (734-02). We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 17, 2021 - 06:35 PST
      Investigating
      We are experiencing SMS delivery failures when sending messages to Venezuela Digitel (734-02). Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 17, 2021 - 05:44 PST
      This incident affected: CARRIER NETWORK (SMS, Latin America).